Установка новой версии офиса LibreOffice на AltLinux

Аватара пользователя
Артём Мамзиков
Admin
Сообщения: 496
Стаж: 3 года 5 месяцев
Откуда: Вологодская область
Поблагодарили: 20 раз
Контактная информация:

Установка новой версии офиса LibreOffice на AltLinux

Сообщение Артём Мамзиков »

На странице загрузки официального сайта LibreOffice выбираем Linux 64x .rpm пакеты для загрузки

Пример libreoffice 7.3.1
По мимо основного архива с пакетами rpm качаем перевод
Переведенный пользовательский интерфейс: Русский
и
Справка для офлайн-использования: Русский

Получаем 3 архива выгружаем все в одну папку RPMS все пакеты .rpm

Далее из папки RPMS нужно удалить следующие пакеты либо переместить.
Сразу убираем kde (libobasis7.3-kde-integration-7.3.0.3-3.x86_64.rpm)

Если не удалить они установятся, но у меня периодически вылетал зависал офис, ругался на java не открывал документы и все 4 раза обновлений от версий одно и то же. Можете попробовать поставить возможно у вас все ок будет.

Убираем все extension пример для версии 7.3 убираем пакеты:
libobasis7.3-extension-beanshell-script-provider-7.3.0.3-3.x86_64.rpm
libobasis7.3-extension-javascript-script-provider-7.3.0.3-3.x86_64.rpm
libobasis7.3-extension-mediawiki-publisher-7.3.0.3-3.x86_64.rpm
libobasis7.3-extension-nlpsolver-7.3.0.3-3.x86_64.rpm
libobasis7.3-extension-pdf-import-7.3.0.3-3.x86_64.rpm
libobasis7.3-extension-report-builder-7.3.0.3-3.x86_64.rpm

Переходим в данную папку cd RPMS и запускаем установку нового офиса
Запустить команду rpm -U *.rpm
После завершения выполнения данного команды должны установится все пакеты.
Новый офис установлен.

Либо можно ставить каждый пакет по раздельности но в определенной последовательности
Установка каждого пакета
Показать

ВЕРСИЯ 7.1
rpm -U libobasis7.1-base-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-ooolinguistic-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-postgresql-sdbc-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-python-script-provider-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-calc-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-pyuno-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-core-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-ru-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-draw-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-ru-help-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-en-US-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-writer-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-extension-beanshell-script-provider-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-xsltfilter-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-extension-javascript-script-provider-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-extension-mediawiki-publisher-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-base-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-extension-nlpsolver-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-calc-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-extension-pdf-import-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-dict-en-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-extension-report-builder-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-dict-es-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-firebird-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-dict-fr-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-gnome-integration-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-dict-ru-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-graphicfilter-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-draw-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-images-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-en-US-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-impress-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-freedesktop-menus-7.1.4-2.noarch.rpm
rpm -U libobasis7.1-librelogo-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-impress-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-libreofficekit-data-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-math-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-math-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-ru-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-ogltrans-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-ure-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-onlineupdate-7.1.4.2-2.x86_64.rpm
rpm -U libreoffice7.1-writer-7.1.4.2-2.x86_64.rpm
rpm -U libobasis7.1-ooofonts-7.1.4.2-2.x86_64.rpm

ВЕРСИЯ 7.3 порядок не правильный!
rpm -U libobasis7.3-onlineupdate-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-ooofonts-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-base-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-ooolinguistic-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-calc-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-postgresql-sdbc-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-core-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-python-script-provider-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-draw-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-pyuno-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-en-US-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-writer-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-extension-beanshell-script-provider-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-xsltfilter-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-extension-javascript-script-provider-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-extension-mediawiki-publisher-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-base-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-extension-nlpsolver-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-calc-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-extension-pdf-import-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-dict-en-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-extension-report-builder-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-dict-es-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-firebird-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-dict-fr-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-gnome-integration-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-draw-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-graphicfilter-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-en-US-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-images-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-freedesktop-menus-7.3.0-3.noarch.rpm
rpm -U libobasis7.3-impress-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-impress-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-librelogo-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-math-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-libreofficekit-data-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-ure-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-math-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-writer-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-ogltrans-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-ru-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-dict-ru-7.3.0.3-3.x86_64.rpm
rpm -U libreoffice7.3-ru-7.3.0.3-3.x86_64.rpm
rpm -U libobasis7.3-ru-help-7.3.0.3-3.x86_64.rpm
После того как проверили что новый офис работает, можно удалять старый но не всегда подписан версией а может быть с именем версии.

Удаление старого офиса LibreOffice-still (4 пакета)


Что касаемо ошибок при установленных пакетах extension
Libra jre
Libra jre
Libra6.4
Libra6.4
Libra7.3
Libra7.3
Для выполнения данного задания libreoffice необходимо установленное окружение java jre

Найдено в интернете на форумах
то при запуске LO запускается расширение, которое требует Java.
Просмотрите список расширений LO и отключите ненужные.

Проверьте, включена ли виртуальная машина в настройках LibreOffice:
Сервис->Параметры->LibreOffice->Расширенные возможности->Использовать виртуальную машину Java.
Убедитесь, что опция включена и выбрана установленная версия (jre).

Установить 32 разрядную JRE.

Удаляю все extensions от LibreOffice
apt-get remove LibreOffice-still-extensions
apt-get remove libobasis.*-extension-beanshell-script-provider
apt-get remove libobasis.*-extension-javascript-script-provider
apt-get remove libobasis.*-extension-mediawiki-publisher
apt-get remove libobasis.*-extension-nlpsolver
apt-get remove libobasis.*-extension-pdf-import
apt-get remove libobasis.*-extension-report-builder


Попытки без удаления extensions пакетов , установка Java 32bit , так же установка новых версий ниже пример, ничего не помогло.

Было
java -version
openjdk version "1.8.0_212"
OpenJDK Runtime Environment (build 1.8.0_212-b04)
OpenJDK 64-Bit Server VM (build 25.212-b04, mixed mode)

Установка новой версии
apt-get install java-1.8.0-openjdk

Стало
java -version
openjdk version "1.8.0_312"
OpenJDK Runtime Environment (build 1.8.0_312-b07)
OpenJDK 64-Bit Server VM (build 25.312-b07, mixed mode)

Установка 32 бита 86х
apt-get install i586-java-1.8.0-openjdk

Доступны версии
java-1.8.0-openjdk 1.8.0.312.b07-alt1_1jpp8:c9f1+288145.100.1.1@1635178541 [Installed]
java-9-openjdk 9.0.4.11-alt8_6jpp8.M90P.1:c9f1+266813.100.1.1@1614076817
java-11-openjdk 11.0.13.8-alt0.c9.1_1jpp11:c9f1+288154.200.2.1@1635231526
java-1.7.0-openjdk 1.7.0.221-alt2_2.6.18.0jpp8:p9+234505.100.3.2@1563173125

Установил еще 9 и 11 стало 3 версии 2х версий разрядности

Плагин java для mozilla
mozilla-plugin-java-1.8.0-*

Репозитории для AltLinux 8.2
Показать
apt-repo rm all
apt-repo add 'rpm http://ftp.altlinux.org/pub/distributio ... /c8/branch x86_64 classic'
apt-repo add 'rpm http://ftp.altlinux.org/pub/distributio ... /c8/branch noarch classic'
apt-get update



rpm [cert8] http://ftp.altlinux.org/pub/distributions/ALTLinux c9f1/branch/x86_64 classic
rpm [cert8] http://ftp.altlinux.org/pub/distributions/ALTLinux c9f1/branch/x86_64-i586 classic
rpm [cert8] http://ftp.altlinux.org/pub/distributions/ALTLinux c9f1/branch/noarch classic

apt-repo add 'rpm http://ftp.altlinux.org/pub/distributions/ALTLinux p9/branch/x86_64 classic'
apt-repo add 'rpm http://ftp.altlinux.org/pub/distributions/ALTLinux p9/branch/noarch classic'
apt-get update

apt-repo rm all
apt-repo add 'rpm http://ftp.altlinux.org/pub/distributions/ALTLinux c9f1/branch/x86_64 classic'
apt-repo add 'rpm http://ftp.altlinux.org/pub/distributions/ALTLinux c9f1/branch/x86_64-i586 classic'
apt-repo add 'rpm http://ftp.altlinux.org/pub/distributions/ALTLinux c9f1/branch/noarch classic'
apt-get update


# Sisyphus
86x
rpm [alt] http://ftp.altlinux.org/pub/distributio ... x/Sisyphus i586 classic
rpm [alt] http://ftp.altlinux.org/pub/distributio ... x/Sisyphus noarch classic
rpm [alt] http://ftp.altlinux.org/pub/distributio ... x/Sisyphus i586 debuginfo

64-86x
rpm http://ftp.altlinux.org/pub/distributio ... x/Sisyphus x86_64 classic
rpm http://ftp.altlinux.org/pub/distributio ... x/Sisyphus x86_64-i586 classic
rpm http://ftp.altlinux.org/pub/distributio ... x/Sisyphus noarch classic
rpm [alt] http://ftp.altlinux.org/pub/distributio ... x/Sisyphus x86_64 debuginfo


Пакеты
http://ftp.altlinux.org/pub/distributio ... /Sisyphus/
количество слов: 1837
Партнёрская ссылка на Хостинг Beget https://beget.com/p937243

Вернуться в «Linux»